Title

Message

Confirm

<< DiscussionsReply

Disabling autoscroll button doesn't really stop the scrolling

Avatar from Gravatar.com
milasch
10 discussion posts
Disabling autoscroll button doesn't really stop the log from scrolling but keep scrolling from where the scroll position is in the scrollbar.

Using Trial version 4.1.

Am I misusing it? How would I prevent the log from scrolling when it's constantly being written so that I can analyse it without having to stop the application?
Oct 9, 2015  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
We've actually just released LogFusion 4.2 and it should fix this issue up. You can update using the Check for Updates button on the Settings > Options tab.

Please let me know if you still run into this issue after updating to 4.2

Thanks!
Oct 9, 2015  • #2
Avatar from Gravatar.com
walterk82
12 discussion posts
I'm still having this issue. If I am viewing log lines and new entries come in, my screen starts scrolling the equal amount of new lines causing me to loose my place/what I was reading.
Oct 13, 2015  • #3
Avatar from Gravatar.com
milasch
10 discussion posts
Quote:
I'm still having this issue. If I am viewing log lines and new entries come in, my screen starts scrolling the equal amount of new lines causing me to loose my place/what I was reading.


I also experienced the same issue again on 4.2.
Oct 13, 2015  • #4
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Is the scroll bar actually scrolling down to the bottom? Or are the log lines just moving up?
Oct 13, 2015  • #5
Avatar from Gravatar.com
milasch
10 discussion posts
Ok, it just happened again and the log lines are moving up, scroll bar is moving up as well.

EDIT:

All I did was to use the mouse to scroll up in order to make the log stop scrolling. However I'm not sure if this is consistently reproducible.
Oct 13, 2015 (modified Oct 13, 2015)  • #6
Keith Lammers (BFS)'s profile on WallpaperFusion.com
It sounds like auto-scroll was enabled on your machine. You can enable/disable it with the far-left button on the toolbar (looks like 2 downward arrows), and it will also disable if you scroll up
Oct 14, 2015  • #7
Avatar from Gravatar.com
milasch
10 discussion posts
Quote:
It sounds like auto-scroll was enabled on your machine. You can enable/disable it with the far-left button on the toolbar (looks like 2 downward arrows), and it will also disable if you scroll up


I disabled it by scrolling up as per my post. I have seen the issue multiple times. Issue is still there, less often though. Believe me. It is still there
Oct 14, 2015  • #8
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Can you provide a debug log for this? Here are the steps:
  • On the Troubleshooting tab, change the Logging drop-down to "L1: Logging Minimal"
  • Restart LogFusion
  • Disable auto-scroll, confirm that it's still scrolling, then scroll up and confirm that it's stopped scrolling
  • Send us the LogFusion.log file (can be found by clicking the Open Log button on the Troubleshooting tab)
  • Disable debug logging after sending the log
Oct 15, 2015  • #9
Avatar from Gravatar.com
milasch
10 discussion posts
Will do as soon as I come across it again.
Oct 15, 2015  • #10
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Perfect, thanks!
Oct 15, 2015  • #11
Avatar from Gravatar.com
Chad Premoe
3 discussion posts
Keith, I'm still seeing the issue in 4.2 whereby the log continues to scroll when it reaches the max loaded log lines. I've captured a log as you described above. I also uploaded a video of it happening. Let me know if there's anything else i can provide.
• Attachment [protected]: LogFusion.log [42,688 bytes]
• Attachment [protected]: Video_2015-11-03_100834.wmv [7,500,870 bytes]
Nov 3, 2015  • #12
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Yeah, we thought we had this all fixed up but it's still busted. I will post an update when we do have it fixed up properly
Nov 3, 2015  • #13
Avatar from Gravatar.com
MichaelS
9 discussion posts
Hoping for an update on this soon It is really annoying.
Nov 18, 2015  • #14
Keith Lammers (BFS)'s profile on WallpaperFusion.com
I believe we'll have it fixed up for the next version, but I can't provide an ETA on that at the moment. Sorry!
Nov 18, 2015  • #15
Avatar from Gravatar.com
milasch
10 discussion posts
OK I experienced the problem again today on two new installations in our site.

I am theorizing a potential cause to problem on version 4.2. When limiting "Maximum loaded log lines" and that value is exceeded, the top part of the log starts getting cropped. When new lines are written it is as if lines are moving onto a FIFO queue.
Nov 23, 2015  • #16
Avatar from Gravatar.com
rsargent
3 discussion posts
Any update? This makes it really hard to use Log Fusion.
Jan 18, 2016 (modified Jan 18, 2016)  • #17
Avatar from Gravatar.com
milasch
10 discussion posts
Quote:
Any update? This makes it really hard to use Log Fusion.


Try to use a very large number onto Maximum loaded log lines setting
Jan 18, 2016  • #18
Avatar from Gravatar.com
Vivan Shah
3 discussion posts
Any update on this? makes logfusion randomly unusable throughout the day as the logfile grows larger. I've switched back to baretail for the time being.
May 31, 2016  • #19
Keith Lammers (BFS)'s profile on WallpaperFusion.com
We're still planning to fix this up for the next version, though I don't have an ETA on it yet.
Jun 1, 2016  • #20
Avatar from Gravatar.com
MichaelS
9 discussion posts
8 months now and still waiting for a fix Please release an update soon - this bug is soooo annoying!
Jun 30, 2016  • #21
Avatar from Gravatar.com
Janos Vasbanyai14895
1 discussion post
Yeah... What the actual fuck guys?
Jul 13, 2016  • #22
Keith Lammers (BFS)'s profile on WallpaperFusion.com
We've just released LogFusion 5.0 Beta 1 (https://www.logfusion.ca/Download/Beta), and this should be all fixed up. Please let us know if you still run into any trouble after updating.

Thanks!
Sep 12, 2016  • #23
Was this helpful?    
<< DiscussionsReply